Announcement

Collapse
No announcement yet.

PSU Occasionaly making whirring noise

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PSU Occasionaly making whirring noise

    Hi, I bought my computer and put it together myself just 8 months ago.

    Recently on some occasions when turning on my computer my PSU makes a odd whirring sound similar to that of a washing machine, and wonder if anybody knows what my problem is and whether or not I should fill out a returns request.

    This is my computer spec:
    Asus GeForce GTX 560Ti DCII/2DI/1GD5 DirectCU II 1024MB GDDR5 PCI-Express Graphics Card
    1 x Gigabyte GA-M68MT-S2P GeForce 7025/ nForce 630a (Socket AM3) DDR3 PCI-Express Micro-ATX Motherboard
    1 x 750W ARIANET ACE Xtreme ATX2.3 Power Supply
    1 x LiteOn IHAS122-18 22x Internal DVD±R/RW SATA Drive - Black
    1 x Hitachi Deskstar HDT721064SLA360 640GB 3.5" Hard Drive SATA 7200 rpm 16MB Cache - RECERTIFIED
    1 x AMD Phenom II X4 Quad Core 960T Black Edition 95W Edition 3.00GHz (Socket AM3) Processor
    1 x 8GB Exceleram Black Sark Series (2x4GB) DDR3 PC3-12800C9 1600MHz Dual Channel Kit - E30122B
    1 x ARIANET Avenger Midi Tower Gaming Chassis

  • #2
    Sounds like the fan bearings wearing out.

    Could be RMA time, or you could try mounting the PSU upside-down to see if it stops the noise. Not sure how much warranty those units have either.

    For a rig like yours I would normally highly recommend a decent branded PSU around the 500W mark such as http://www.aria.co.uk/Products/Compo...roductId=42489 The PSU isn't something you want to skimp on, so you may wish to consider replacing if/when funds allow
    --
    Fractal R4 (shhh!) 3570k, z77x-d3h, 16gb, R9-270X, 240gb SSD, 2tb mirror w/ 60gb cache drive

    Comment


    • #3
      Thank you for your help

      Comment

      Working...
      X