Announcement

Collapse
No announcement yet.

How to make my wired internet connection available via wifi?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to make my wired internet connection available via wifi?

    My computer is connected to our wireless router via an ethernet cable because the signal is too weak where my pc is.

    But I've got an iPod and more importantly, just got myself a Sony Xperia S which I want to have connected to the internet/wifi while I'm at home.

    I've bought a TP-Link PCIe wifi card from Aria so my PC now has wired and wireless capability, but I can't get it to share the wired internet connection through the wifi?
    Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

    Twitter / Instagram / YouTube

  • #2
    Yes you can, google Virtual Router

    That is of course, if you're on W7

    Comment


    • #3
      I think the problem is that my ICS (Internet Connection Sharing) service is not started, and I can't get it to run.

      Which means windows won't allow the internet to be shared.

      I just downloaded Virtual Router and it just says 'Virtual Router can not be started' when I click the start button.
      Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

      Twitter / Instagram / YouTube

      Comment


      • #4
        cmd > sfc /scannow

        I type 90 WPM, Click Here to try
        i7 3770k @ 4.6ghz | Gigabyte Z77X-UD5H | R9 290| 16GB Ram @ 1600mhz
        Nikon D5100 + Kit Lens + 50mm 1.8G - 16-35mm F4 VR // Ultrasone PRO 2900s - Audio GD NFB-3.1 - Neco Mosfett Amp

        Comment


        • #5
          Originally posted by Naphta View Post
          cmd > sfc /scannow
          Tried that already, it said everything was fine.

          And I've been through the service manager and made sure all the associated services are running too.

          There's pages and pages of people with this same problem, but nobody with an answer
          Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

          Twitter / Instagram / YouTube

          Comment


          • #6
            Originally posted by Cypher View Post
            Tried that already, it said everything was fine.

            And I've been through the service manager and made sure all the associated services are running too.

            There's pages and pages of people with this same problem, but nobody with an answer
            Ooo, things just got interesting!

            Isnt ICS a windows feature you need to enable? Double check that!

            I type 90 WPM, Click Here to try
            i7 3770k @ 4.6ghz | Gigabyte Z77X-UD5H | R9 290| 16GB Ram @ 1600mhz
            Nikon D5100 + Kit Lens + 50mm 1.8G - 16-35mm F4 VR // Ultrasone PRO 2900s - Audio GD NFB-3.1 - Neco Mosfett Amp

            Comment


            • #7
              Hold on, the way I got around it is this, just searchinggggg...


              1. Open command prompt with Administrator privileges. (You can do it by going to start menu, right clicking on command prompt and selecting “Run as administrator”).

              2. Enter the following command:

              netsh wlan set hostednetwork mode=allow ssid=Test key=Passkey
              (This will create a wireless access-point with SSID of “Test”

              Windows-7-Wifi-Setup

              3. Open the Networks and Sharing Center

              4. Select your mode of connecting to the internet (ethernet, wi-fi, cable etc.)

              5. Enable sharing and select special ‘hosted’ interface or Wireless Connection (i.e. Virtual Wifi miniport)

              6. Start it

              netsh wlan start hostednetwork

              Source: http://www.techylabs.com/setting-up-...windows-7.html

              And you’re Done!

              Tips:
              1. Disable IP6 in Microsoft Virtual WiFi Miniport Adapter or other wireless network.
              2.Don't use any Wifi connections before starting Virtual Router may create Problem.
              3.In Device Manage download Online, Latest Microsoft Virtual WiFi Miniport Adapter in case of problem.

              Then after few days try to connect through Virtual Router

              pppoe, you can. Just see this pic to share http://i54.tinypic.com/15moh77.jpg ; My wireless connection 4 is Microsoft Virtual WiFi Miniport Adapter.

              First you need to connect Internet and then start virtual router and then start.
              When You successfully share Internet with virtual router you will see this. http://i53.tinypic.com/300y0ck.jpg

              Network Connections Page: http://i56.tinypic.com/m93gbt.jpg

              Virtual Router Screen Shot: http://i54.tinypic.com/spzrtj.jpg
              Color Red: Confidential
              Color Black: This may confuse you because I already ))

              Hope it Helps and will save time. )

              Comment


              • #8
                Originally posted by garriec View Post
                Hold on, the way I got around it is this, just searchinggggg...
                I've found various different versions of the method you posted, but none work because I cannot enable sharing. See screenshots...





                Added after 4 minutes:

                I've got it to create the new connection called 'Test' which now shows up in the Network and Sharing Centre, but I still can't enable internet connection sharing without getting the error message
                Last edited by Cypher; 27-04-12, 00:09.
                Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

                Twitter / Instagram / YouTube

                Comment


                • #9
                  Oh, that's odd Can't help there I'm afraid!

                  In my case, I received the following message on Vista Ultimate SP1:

                  "An error occurred while Internet Connection Sharing was being enabled.
                  (null)"

                  An easy Google search turned up lots of answers. I combined two to find that the following services must be running, i.e., started and not disabled--ideally "automatic" if you want it to work on restart--for ICS to function properly:

                  Application Layer Gateway Service
                  Network Connections
                  Network Location Awareness (NLA)
                  Plug And Play
                  Remote Access Auto Connection Manager
                  Remote Access Connection Manager
                  Remote Procedure Call (RPC)
                  Telephony
                  Windows Firewall

                  I had--in some stab at wisdom--disabled all the services I wasn't using, and I was not able to start ICS until I went all the way through the list. Unfortunately, I found that Windows Firewall has to be running, even if you're running another product, such as Symantec Endpoint Protection.
                  Any good?
                  Last edited by garriec; 27-04-12, 00:11.

                  Comment


                  • #10
                    Originally posted by garriec View Post
                    Oh, that's odd Can't help there I'm afraid!



                    Any good?
                    Only thing on that list I hadn't already enabled was windows firewall, but still nothing.

                    EDIT: I take that back! I just went back into Network and Sharing Centre and clicked the 'allow this connection to be shared' button and it worked! I now have 'Test' up and running and my phone using the internet through it!

                    It appears that the ICS service can't be started on it's own, it needs an outside application (such as the network) to request that it is started.

                    But either way, enabling windows firewall seems to have sorted it! Thanks for your help!

                    Now just quickly, do I have to open and run the virtual router software everytime I start my computer to re-activate the connection?
                    Last edited by Cypher; 27-04-12, 00:25.
                    Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

                    Twitter / Instagram / YouTube

                    Comment


                    • #11
                      Thanked and repped your last post
                      Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

                      Twitter / Instagram / YouTube

                      Comment


                      • #12
                        TP-Link PCIe wifi card from Aria
                        You could have attached a second wireless router on the end of your cable, connected a cable to that for PC and then have the wireless devices connect to the new wireless router. Not sure on the cost difference but it would not rely on your computer being on all the time.

                        Comment


                        • #13
                          Originally posted by monkey56657 View Post
                          You could have attached a second wireless router on the end of your cable, connected a cable to that for PC and then have the wireless devices connect to the new wireless router. Not sure on the cost difference but it would not rely on your computer being on all the time.
                          Ooh now he tells me

                          Yee that's probably what I should have done, but 20 for a triple antenna wireless-n card was a much cheaper solution that a router.

                          Plus my computer gets turned on as soon as I get home, and it's the last thing to go off before bed so the network is always available
                          Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

                          Twitter / Instagram / YouTube

                          Comment


                          • #14
                            That photoshop better be legit!
                            The North will never forget!

                            Comment


                            • #15
                              Originally posted by Dillon View Post
                              That photoshop better be legit!
                              haha, of course!

                              The hassle I had trying to get it on this computer though! Because Ive had it a few years it been on several different computers, but I keep forgetting to de-authorise it before I change computers/do re-installs etc.

                              But the lady at Adobe was very helpful in getting me registered on my current rig
                              Intel i5-2500K @ 4GHz | 8GB 1600MHz DDR3 | ASUS GTX 970 | 500GB Samsung 850 EVO | Corsair H60 | ASUS Xonar DG 5.1 | Samsung Blu-Ray | BitFenix Spectre PRO LED Fans | Corsair SP2500 2.1 | ASUS 29" 2560x1080 IPS

                              Twitter / Instagram / YouTube

                              Comment

                              Working...
                              X