Announcement

Collapse
No announcement yet.

meebox owners club

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by asantaga View Post
    I dont have access to my NAS at the moment but issue the following commands, it will tell you where the file is

    find /opt -name "settings.json" -print

    if this doesnt return anything try

    find / -name "settings.json" -print
    Excuse me if i am being dumb lol but still got problems with that.

    I started the guide from scratch again after the above quoted part didn't work and get to the following step but i don't have a settings.json file
    Look for the following line in the settings.json file and make sure its set to false

    "rpc-whitelist-enabled": false,
    I am following the guide 100% but not sure if i am doing anything wrong? I have saved my telent text if that will help - http://pastebin.com/atiPjVyZ
    "They're gonna find out
    I don't know who they are or what they're gonna find out
    But they're gonna find out
    And it's gonna be over real quick"

    Comment


    • ok, it looks like /opt isnt being persisted between reboots.. I need to look at this..

      I will look tonight where my settings.json file is...

      Comment


      • Hi all... been lurking for a few days now, managed to get all set up and running thanks to the guidance of a few members here

        Twonky and Transmission now working flawlessly (thanks @asantaga ).

        @darklighthim I had the same problem as you, followed guide but still couldnt find setting.json using :

        "find / -name "settings.json" -print"

        What worked for me was;
        stop transmission using "killall -9 transmission-daemon"
        using ftp client (i used filezilla) delete the folder /mnt/opt , and the symlink in / .
        follow the guide again from the top
        then you should find setting.json in /root/.config/transmission-daemon

        I edited this to disable whitelist - no luck getting it to work
        also tried adding my IP to whitelist -still no joy

        finally resorted to using telnet to start up the daemon using a few conditions

        /opt/bin/transmission-daemon -p 9091 -f -T -a [IP ADDRESS HERE] -w /mnt/ide3/[WHEREVER YOU WANT TO SAVE TORRENTS]

        This worked a treat.

        hope my very limited input helps

        Www

        Comment


        • Thanks WordsWorse but still hasn't worked for me yet
          "They're gonna find out
          I don't know who they are or what they're gonna find out
          But they're gonna find out
          And it's gonna be over real quick"

          Comment


          • Does anyone know how to change the default web port for the built in apache server? It's obviously default port 80, but there is no way in the control panel to change this so wondering if I can change it by command line?

            Comment


            • Originally posted by darklighthim View Post
              Thanks WordsWorse but still hasn't worked for me yet
              What WordsWorse said worked for me!

              Step 1) in Telnet do: killall -9 transmission-daemon
              Step 2) from Fliezilla (or ftp with sftp compatiblity): delete /mnt/opt , and the symlink in /
              Step 3) in Filezilla go to root/.config/ and delete the transmission-daemon folder
              Step 4) follow the install intructions again.
              Step 5) the settings file and folder "shouldn't" be there now when you get to the edit settings.json part so
              creat a new folder inside the /root/.config/ folder called "transmission-daemon"
              Step 6) creat a new file on your computer with the name "settings.json" and edit it so it contains
              {
              "alt-speed-down": 50,
              "alt-speed-enabled": false,
              "alt-speed-time-begin": 540,
              "alt-speed-time-day": 127,
              "alt-speed-time-enabled": false,
              "alt-speed-time-end": 1020,
              "alt-speed-up": 50,
              "bind-address-ipv4": "0.0.0.0",
              "bind-address-ipv6": "::",
              "blocklist-enabled": false,
              "dht-enabled": true,
              "download-dir": "\/mnt\/ide3\/transmissionDownloads",
              "encryption": 0,
              "incomplete-dir": "\/root\/.config\/transmission-daemon\/Incomplete",
              "incomplete-dir-enabled": false,
              "lazy-bitfield-enabled": true,
              "message-level": 2,
              "open-file-limit": 32,
              "peer-limit-global": 240,
              "peer-limit-per-torrent": 60,
              "peer-port": 51413,
              "peer-port-random-high": 65535,
              "peer-port-random-low": 49152,
              "peer-port-random-on-start": false,
              "peer-socket-tos": 0,
              "pex-enabled": true,
              "port-forwarding-enabled": true,
              "preallocation": 1,
              "proxy": "",
              "proxy-auth-enabled": false,
              "proxy-auth-password": "",
              "proxy-auth-username": "",
              "proxy-enabled": false,
              "proxy-port": 80,
              "proxy-type": 0,
              "ratio-limit": 2.0000,
              "ratio-limit-enabled": false,
              "rename-partial-files": true,
              "rpc-authentication-required": false,
              "rpc-bind-address": "0.0.0.0",
              "rpc-enabled": true,
              "rpc-password": "{46370709332fecf1a9cb5a704ee098e382939f16fPbrdf0j ",
              "rpc-port": 9091,
              "rpc-username": "",
              "rpc-whitelist": "192.168.0.4",
              "rpc-whitelist-enabled": false,
              "speed-limit-down": 100,
              "speed-limit-down-enabled": false,
              "speed-limit-up": 100,
              "speed-limit-up-enabled": false,
              "umask": 18,
              "upload-slots-per-torrent": 14
              }

              and change (if required)

              "rpc-whitelist": "192.168.0.4",
              "rpc-whitelist-enabled": false,

              save the file and upload to the new folder you created.

              Step 7) finish installation

              mkdir /mnt/ide3/transmissionDownloads
              transmission-daemon -w /mnt/ide3/transmissionDownloads

              and portward if not done already, mines working now!! thanks for the help everyone!!

              Comment


              • When you say creat a new folder inside the /root/.config/ folder called "transmission-daemon" i don't see the .config folder?

                All i have is /ide3 folder on the meebox and everything is in that but no .config anywhere inside ide3 or outside it on root. I also don't have symlink in /
                Last edited by darklighthim; 12-04-12, 21:13.
                "They're gonna find out
                I don't know who they are or what they're gonna find out
                But they're gonna find out
                And it's gonna be over real quick"

                Comment


                • in the host address type sftp:YOUR_NAS_IP and then it should ask you about some key just click accept then you can access the whole file system.

                  you'll have to enable SSH/SFTP (openSSH ) option under Advanced Settings/Service Control
                  Last edited by peterjones; 12-04-12, 21:21.

                  Comment


                  • Originally posted by peterjones View Post
                    in the host address type sftp:YOUR_NAS_IP and then it should ask you about some key just click accept then you can access the whole file system.

                    you'll have to enable SSH/SFTP (openSSH ) option under Advanced Settings/Service Control
                    I take it your meaning in filezilla?
                    "They're gonna find out
                    I don't know who they are or what they're gonna find out
                    But they're gonna find out
                    And it's gonna be over real quick"

                    Comment


                    • root access

                      Originally posted by darklighthim View Post
                      I take it your meaning in filezilla?
                      if you login with filezilla using admin account you will be able to navigate all the way up to the root dir (/)
                      the should be a folder called root there

                      Comment


                      • in filezilla the host box (top left) has sftp://YOUR_NAS_IP

                        and in http://meebox:8090/login.cgi

                        you'll have to enable SSH/SFTP (openSSH ) option under Advanced Settings/Service Control

                        if you haven't already.

                        Comment


                        • Having logged in several times in the past with filezilla i have never seen a root folder?
                          "They're gonna find out
                          I don't know who they are or what they're gonna find out
                          But they're gonna find out
                          And it's gonna be over real quick"

                          Comment


                          • you MUST log in using the sftp mode then once you've managed to get onto the server you then can go backwards via the folder at the top ".." to then see the root folder.

                            Comment


                            • right so in the host box i have put has sftp://YOUR_NAS_IP then my admin login plus port but get the following. I have enabled SSH/SFTP (openSSH ) within the meebox
                              Status: Connecting to 192.168.10.1:21...
                              Response: fzSftp started
                              Command: open "admin@192.168.10.1" 21
                              Error: Connection timed out
                              Error: Could not connect to server
                              Status: Waiting to retry...
                              Status: Connecting to 192.168.10.1:21...
                              Response: fzSftp started
                              "They're gonna find out
                              I don't know who they are or what they're gonna find out
                              But they're gonna find out
                              And it's gonna be over real quick"

                              Comment


                              • try sftp://meebox

                                you should get a message box pop up ("Unknow host key") asking you to "Always trust this host, add this key to the cache", tick the box and click ok

                                Comment

                                Working...
                                X