No announcement yet.

My Dell Latitude 3540 laptops won't accept new RAM

  • Filter
  • Time
  • Show
Clear All
new posts

  • My Dell Latitude 3540 laptops won't accept new RAM

    Hi all,

    I have Dell Latitude 3540 with 4GB of RAM and want to upgrade it to 8GB but when I try to install 2nd stick of 4 GB my laptop won't boot( no POST screen either ) , it sounds like it keeps trying to switch on but fails.

    I have bought 2 sticks of RAM from different ebay sellers but it just does the same thing.

    I have tried these RAM I bought on it's own in my laptop and with one of them it takes ages to go to desktop, with second stick on it's own it just won't boot up at all.

    The memory is correct as far as I can tell and the same manufacture( btw my Dell laptop has Kingston RAM for some reason )...... any ideas why this is happening?

  • #2
    Sounds like two dead sticks of ram if you've tried them independently.

    Time to raise refund requests.

    Not sure I ever trust 2nd hand ram that mush - is the price difference from new worth it?

    Please see thread, here for how post reports are dealt with.
    Forum Guidelines here


    • #3
      Does it need some BIOS tweak for the RAM timing, or something like that?
      Win 10 Pro 64-bit + Asus Z-170-K + Intel i5-6500 + 512GB Samsung M.2 PCI-e SSD + 16GB DDR4 2400MHz Memory
      Win 10 Pro 64-bit + Asus M5A88-M EVO + AMD Phenom II X6 + 8GB Corsair XMS3 1600 + Radeon HD 6450
      Win 10 Home 32-bit + Asus M2N-SLI DeLuxe + AMD Athlon 64 X2, Dual Core 5400 + 4.0 GB Memory + NVIDIA GeForce 8600 GT


      • #4
        I won a mini-PC a few months back that NEEDED 1333mhz sodimms. 1600mhz wasn't recognised at all.

        Double check the specs.
        Fractal R4 (shhh!) 3570k, z77x-d3h, 16gb, R9-270X, 240gb SSD, 2tb mirror w/ 60gb cache drive


        • #5
          Could be a dodgy ram slot. Have you tried the ram you bought on eBay in the slot that had the original ram installed? And have you tried your original stick that's known working, in the second slot?


          • #6
            yeap two faulty memory sticks.... the 3rd one works just fine, thanks for all your replies