Announcement

Collapse
No announcement yet.

Has my cpu died?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Has my cpu died?

    Hey all, my girlfriends pc suddenly went pop and all shutdown. The motherboard and usb devices were still receiving power but when pressing the power button or even the start button on the motherboard, nothing happens. I've swapped the psu out with a working one from another pc and still only mobo and usb power. Never had this happen before but I would guess it's the cpu?

    I don't have another board to test the cpu so I'm not sure where I go from here. I bought the pc in June 2014.

    Anyone able to provide any advice?
    Intel i7 3770k @4.5GHz | ASUS Sabertooth z77 | 16GB Mushkin 2400MHz RAM | 120GB Samsung Evo for OS | 240GB Mushkin SSD | 2TB Barracuda SATA III | MSI GTX 980 4G Twin Frozr V | Corsair H80 | CM Storm Enforcer Case | Razer Naga Molten | Corsair K70 Red Switches | Blue Yeti Mic | Microsoft Lifecam Studio

  • #2
    CPU's rarely die but not impossible. I'm thinking its more likely the PSU has gone and taken another component with it. Possible the motherboard.

    I'm assuming your not getting any beeps or anything from the motherboard?
    i7 2600K @ 4.5| Asrock Z68 Extreme4| 16GB 1866Mhz Crucial Ballistix |AMD R9 290| 120GB SSD |Win7 64bit

    Comment


    • #3
      No beeps, just lights at the back and on the start button and it provides power to mouse and keyboard as they light up.
      Intel i7 3770k @4.5GHz | ASUS Sabertooth z77 | 16GB Mushkin 2400MHz RAM | 120GB Samsung Evo for OS | 240GB Mushkin SSD | 2TB Barracuda SATA III | MSI GTX 980 4G Twin Frozr V | Corsair H80 | CM Storm Enforcer Case | Razer Naga Molten | Corsair K70 Red Switches | Blue Yeti Mic | Microsoft Lifecam Studio

      Comment


      • #4
        Time to strip it right down to basics, reset bios, remove GPU and boot from iGPU if possible. Use just one stick of ram and remove all unnecessary USB devices etc.

        See if you can at least get to BIOS but my monies still on mobo ATM.

        Have a look for any burn marks anywhere on the motherboard.

        Full system specs will help as well.
        i7 2600K @ 4.5| Asrock Z68 Extreme4| 16GB 1866Mhz Crucial Ballistix |AMD R9 290| 120GB SSD |Win7 64bit

        Comment


        • #5
          False alarm, it was the GPU, never thought a dead gpu would stop pc from booting. Sorry to waste your time mate but I appreciate the advice.
          Intel i7 3770k @4.5GHz | ASUS Sabertooth z77 | 16GB Mushkin 2400MHz RAM | 120GB Samsung Evo for OS | 240GB Mushkin SSD | 2TB Barracuda SATA III | MSI GTX 980 4G Twin Frozr V | Corsair H80 | CM Storm Enforcer Case | Razer Naga Molten | Corsair K70 Red Switches | Blue Yeti Mic | Microsoft Lifecam Studio

          Comment


          • #6
            Glad you found the faulty component
            i7 2600K @ 4.5| Asrock Z68 Extreme4| 16GB 1866Mhz Crucial Ballistix |AMD R9 290| 120GB SSD |Win7 64bit

            Comment


            • #7
              Glad it's sorted. As above, the CPU is normally the last thing to go. PSU, motherboard, GPU, ram all much more likely candidates (in roughly that order of likeliness, from my experience).

              Comment

              Working...
              X